Posted on

Updating Themes “Incompatible Archive”

In the recent past there has been an issue with the functionality of the WordPress automatic updater. If you have tried to update from an older version of one of our themes using via the wordpress controll panel and are getting errors such as “Incompatible Archive. PCLZIP_ERR_BAD_FORMAT (-10)” there are two solutions:

  1. The first solution is logically enough to upgrade WordPress, It has been reported that this known issue was fixed in WordPress version 2.83. In most cases this will fix the issue.
  2. If you already have the latest version of WordPress and are still receiving the error or there is something preventing you from upgrading to the newest version of WordPress the you will need to delete the installed theme and do a fresh installation.
    • Go into themes and delete the theme you wish to update.
    • When done click on the “Install Themes” tab, now search for the theme and install it.

One of these solutions should fix the issue.

If you are sick of the occasional sighting of the theme you are using on other’s sites, hire us to create an exclusive custom design just for you. Read more about our Affordable Web Design.

Leave a Reply

Your email address will not be published. Required fields are marked *